Forum maken

Post hier alle vragen rond HTML, PHP, MySQL, Javascript, Perl etc., plaats hier sitechecks.of vraag om linkpartners
Plaats reactie
Gebruikersavatar
juk
Gast

Forum maken

Bericht door juk » 08 jul 2008 20:07

Ik heb met wamp een site gemaakt en met php. Ik maakte een forum maar het verzenden werkt niet. Ik heb dit als de code:
<html>
<head><title>Jhorie</title>
<body>

<?php
if(isset($_POST['verzenden'])){
$ontvanger=jhorie1995@hotmail.com;
$onderwerp="Contact-formulier";
$verzender="From: " . $_POST['email'];
$bericht="Dit is een email van de website.\n";
$bericht.="Het bericht is gestuurd door:" . $_POST['naam'] . "\n";
$bericht.="Het bericht:\n";
$bericht.=$_POST['boodschap'] . "\n\n";
$bericht.="Einde van dit automatisch gegenereerde bericht.";
mail($ontvanger,$onderwerp,$bericht,$verzender);
}else{
?>
<form action="index.php" method="post">
<table>
<tr><td>Uw naam:</td><td><input type="text" name="naam"></td></tr>
<tr><td>Uw emailadres:</td><td><input type="text" name="email"></td></tr>
<tr><td>Uw boodschap:</td><td><textarea name="boodschap"></textarea></td></tr>
<tr><td colspan="2"><input type="submit" name="verzenden"><br>
</table>
<form>
<?php
}
?>


</body>
</html>

en dit komt er als warning ofso:
Nu gaan we de verzender en het bericht aangeven.
Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\wamp2\www\index.php on line 21

Dit staat er dan.
Alsjeblieft help me

Gebruikersavatar
ktf
Beheerder
Beheerder
Berichten: 1229
Lid geworden op: 14 feb 2006 21:47
Contacteer:

Re: Forum maken

Bericht door ktf » 08 jul 2008 20:37

Je hebt blijkbaar geen mailserver op je computer staan. Een mailserver is een programmaatje waarmee je computer mails kan verzenden (en dan niet zoiets als Outlook Express of Thunderbird, die verbinden je alleen met de servers van je internetprovider)

Je zult een mailserver moeten installeren, maar je internetprovider blokkeert die waarschijnlijk. (dat is tegen spam) Kun je even doorgeven wie je als internetprovider hebt, dan kan ik je verder helpen. :)
Verbruik van mijn laptopje+randapparatuur:
Gemiddeld: 27,1W (non-stop gemeten, 95 dagen lang)
Maximaal: 101W
Kosten per jaar: 23,76 euro (bij 10 cent per kWh)

Gebruikersavatar
juk
Gast

Re: Forum maken

Bericht door juk » 08 jul 2008 20:51

Ik heb kpn experia box en het is een speedtouch 780i wl

Gebruikersavatar
mollerpunker
ICER-junk
ICER-junk
Berichten: 691
Lid geworden op: 17 feb 2006 14:42
Locatie: Bergen op Zoom
Contacteer:

Re: Forum maken

Bericht door mollerpunker » 08 jul 2008 21:09

dat is je modem ;) je zit dus bij kpn als ik het zo lees. als je wilt weten wat voor spam je heb moet je inloggen met je gegevens op de webmail.
1 tip steek geen kapot usb stekkertje in je poort :P je blaast alles op :D

Gebruikersavatar
ktf
Beheerder
Beheerder
Berichten: 1229
Lid geworden op: 14 feb 2006 21:47
Contacteer:

Re: Forum maken

Bericht door ktf » 08 jul 2008 21:09

Dat is je router.... nouwjah, ik ga er dus vanuit dat je met KPN werkt. Je kunt hier een erg goede mailserver vinden: http://www.argosoft.com/RootPages/MailS ... fault.aspx

Je moet hem wel zo instellen dat hij de mail doorstuurt naar je provider. Je moet het SMTP adres opzoeken, wat je op de website van je provider of in je e-mailprogramma kunt vinden. Zoek bij de instellingen Smart Server op, vul het adres in, en klik op Always use Smart Server. Veel succes!
Verbruik van mijn laptopje+randapparatuur:
Gemiddeld: 27,1W (non-stop gemeten, 95 dagen lang)
Maximaal: 101W
Kosten per jaar: 23,76 euro (bij 10 cent per kWh)

Plaats reactie