[CSS] menu werkt niet goed

Post hier alle vragen rond HTML, PHP, MySQL, Javascript, Perl etc., plaats hier sitechecks.of vraag om linkpartners
Plaats reactie
Gebruikersavatar
mollerpunker
ICER-junk
ICER-junk
Berichten: 691
Lid geworden op: 17 feb 2006 14:42
Locatie: Bergen op Zoom
Contacteer:

[CSS] menu werkt niet goed

Bericht door mollerpunker » 20 jan 2007 12:49

http://jps.downfire.com/index.html
als ik mijn sub menu uit vouw onder info, en ik klik weer op info dan wordt mijn menu breder :? iemand oplossing ? ik heb een bestand genaamd info.html kijk hier onder

het tweede probleem is dat mijn tekst halver wege het menu staat inplaats van er naast .... hier ook iets voor ?

Code: Selecteer alles

<body background="army.jpg" text="black">
<img src="banner.gif" border="0">
 <font size="3" face="Comic sans MS, Arial, Times New Roman" color="black">
  <script>
   function expandOrCollapse(menu)
   {
     var ul = menu.nextSibling;
     while(ul.tagName != "UL") // Search for the next UL tag
     {
       ul = ul.nextSibling;
       if ( ul == null )
         return true;
     }
     if (    ul.style.display == "none"  
          || ul.style.display == "" )
       ul.style.display = "block";
     else  
       ul.style.display = "none";
     return false;
   }
  </script>
 </head> 
 <body>
  <div id="menu">
   <ul>
    <li>
     <a href="index.html">home</a>
    </li>
    <li>
     <a href="join.html">join</a>
    </li>
    <li>
     <a href="challenge.html">challenge us?</a>
    </li>
    <li>
     <a href="info.html" onClick="return expandOrCollapse(this);">info</a>
     <ul class="submenu">
      <li>
       <a href="game.html">game</a>
      </li>
      <li>
       <a href="rules.html">clan rules</a>
      </li>
     </ul> 
    </li>
    <li>
     <a href="links.html">links</a>
     </li>
    <li class="last">
     <a href="forum.html">forum</a>
    </li>
   </ul>
  </div> 
 </body>
<b>
THIS PAGE IS UNDERCONSTRUCTION
</b>
</body>
</head>
</html>
en een def.css bestand zie:

Code: Selecteer alles

body
   
   #menu
   {
     float: left;
     margin:3px;
   }
   #menu ul
   {
     list-style:none; 
     margin-left:3pt;
   }
  
   #menu ul.submenu
   {
     margin-left:3px;
   }

   #menu li a
   { 
     display:block;
     padding: 10px 10px 5px 1.0em;
     border-left: 10px solid darkseagreen;
     border-right: 10px solid darkseagreen;
     background-image: url(camouflage.gif);
     color: black;
     text-decoration: none;  
     width:100%;
   } 

   #menu li a:hover
   {
     border-left: 10px solid seagreen;
     border-right: 10px solid seagreen;
     background-image: url(ca.gif);
     color: black;
   }
1 tip steek geen kapot usb stekkertje in je poort :P je blaast alles op :D

Gebruikersavatar
ktf
Beheerder
Beheerder
Berichten: 1229
Lid geworden op: 14 feb 2006 21:47
Contacteer:

Bericht door ktf » 20 jan 2007 16:04

Van het eerste probleem heb ik bij opera geen last, dus dat ligt vast aan FF ;)
Haal float: left; eens weg. Misschien dat dat helpt. (Ja ik weet het, ik heb je zelf de tip gegeven om het erin te zetten)
Verbruik van mijn laptopje+randapparatuur:
Gemiddeld: 27,1W (non-stop gemeten, 95 dagen lang)
Maximaal: 101W
Kosten per jaar: 23,76 euro (bij 10 cent per kWh)

Gebruikersavatar
mollerpunker
ICER-junk
ICER-junk
Berichten: 691
Lid geworden op: 17 feb 2006 14:42
Locatie: Bergen op Zoom
Contacteer:

Bericht door mollerpunker » 20 jan 2007 18:35

ik heb het geprobeerd maar het maakt niets uit.... ik moet er wel bij zeggen dat hij het offline dus op mijn pc het helemaal goed is maar online niet op jps.downfire.com .................
1 tip steek geen kapot usb stekkertje in je poort :P je blaast alles op :D

Plaats reactie